Need help with OpenStudio SketchUp plugin setup.

asked 2017-10-04 21:14:34 -0600

maddog56 gravatar image

updated 2017-10-05 13:46:16 -0600

Ok,

I'm an old BLAST user from way back and I'm trying to get caught up with all the new bells and whistles associated with EnergyPlus 8.7. I downloaded and installed SketchUp Pro 2017 and then downloaded and installed OpenStudio 2.2.0. Upon opening SketchUp I get the errors seen below. I then copied the file openstudio.so to C:\Program Files\SketchUp\SketchUp 2017\Tools so that it sits next to the file openstudio.rb. When SketchUp is restarted the error message does not appear but I have no OpenStudio menus or toolbars in SketchUp.

Error Loading File OpenStudio.rb Error: #<loaderror: cannot="" load="" such="" file="" --="" c:="" program="" files="" sketchup="" sketchup="" 2017="" tools="" openstudio.so=""> C:/Program Files/SketchUp/SketchUp 2017/Tools/OpenStudio.rb:55:in require_relative' C:/Program Files/SketchUp/SketchUp 2017/Tools/OpenStudio.rb:55:in<top (required)&gt;'<="" p="">

edit retag flag offensive close merge delete

Comments

what operating system are you on? I've never had to copy an openstudio.so file to SketchUp tools directory. Maybe try deleting this, then reinstalling OpenStudio and see if you get the same error?

mdahlhausen gravatar imagemdahlhausen ( 2017-10-05 17:31:37 -0600 )edit

Well I continued to play around with various software combinations and the pairing of Sketch Make 2017 (not Pro version) and OS 2.3.0 seemed to finally work. I did read various conflicting advice on this matter from various places so sometimes you just have to be lucky and persistent. Thanks.

maddog56 gravatar imagemaddog56 ( 2017-10-05 18:51:44 -0600 )edit

great. glad you figured it out.

mdahlhausen gravatar imagemdahlhausen ( 2017-10-05 19:12:30 -0600 )edit