Question-and-Answer Resource for the Building Energy Modeling Community
Get started with the Help page
Ask Your Question
1

ideal air loads and openstudio

asked 2017-05-12 22:20:04 -0500

Matt Koch gravatar image

updated 2017-05-13 17:01:56 -0500

So, I was perusing the web on the subject, and I am not sure I am interpreting what I found correctly. However, here is my - possibly erroneous - take on it.

1) In order to avoid having to model any HVAC loops, I have to use ideal air loads - yes, no?

2) When using ideal air loads, no outdoor air is being included in the calculations - ever - no matter what is entered under Spaces -> Airflow -> Design Specification Outdoor Air Object Name?

3) Hence, if I do want to investigate outdoor air, I must model my HVAC loops?

I'd appreciate your advice on this.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
2

answered 2017-05-15 11:31:40 -0500

I made an EnergyPlus measure that loops through each zone and injects the Design Specification Outdoor Air object into the Ideal Loads Air System object. I also made it possible to edit other fields and add reporting variables as a default.

image description

edit flag offensive delete link more

Comments

So, I was trying to use this measure in PAT (1.14.0) just now. However, in "Organize and Edit Measures for Project", the measure has a red exclamation mark, and when clicking on the measure, the three schedule choices are red, just as shown in the above image. I cannot make any selections here, and the out.idf file likewise shown empty entries for these, so I should not have to make any selections, or they should default to empty? Any thoughts? In the meantime, I have written a Scilab script to accomplish what I did manually below, but it would be nice to have a working official measure.

Matt Koch gravatar imageMatt Koch ( 2017-05-15 14:35:04 -0500 )edit

you need to create a Schedule:Ruleset object that is the Availability schedule for your HVAC system. If you want it always on, you can create a default schedule that is always 1. Use Schedule Type OnOff.

mdahlhausen gravatar imagemdahlhausen ( 2017-05-15 15:13:50 -0500 )edit

So, looks like this only works when there are OA specifications of all zones. I have some plenum zones for which I have no OA specification. I suspect that is why the simulation fails with the following error?

"Error: Unable to find design specification outdoor air for zone TZ-FA-PC. Please specify a design specification outdoor air object for the zone, or select None for Outdoor Air Specification."

Matt Koch gravatar imageMatt Koch ( 2017-05-19 11:27:18 -0500 )edit

OK, so I simply commented out the following two lines:

#runner.registerError("Unable to find design specification outdoor air for zone #{zone_name}. Please specify a design specification outdoor air object for the zone, or select None for Outdoor Air Specification.") #return false

in the measure.rb file, and now it runs through, and also delivers the same results that I had obtained earlier through my "non-conformist" approach.

Matt Koch gravatar imageMatt Koch ( 2017-05-19 11:42:21 -0500 )edit

The measure is exiting at that error. You can modify the measure to skip the plenum zones (you'd need a way to tell the measure which zones to skip), or alternately, create a plenum space type with zero values in the design specification outdoor air and then have your plenum zones have spaces of that space type.

mdahlhausen gravatar imagemdahlhausen ( 2017-05-19 12:20:15 -0500 )edit
1

answered 2017-05-12 22:23:29 -0500

Matt Koch gravatar image

So, I set up a model in SketchUp/OpenStudio and ran it with ideal air loads in OpenStudio/EnergyPlus. If I understand correctly, this does not include outdoor air, even though I specified such in SketchUp/OpenStudio. In reviewing the "eplustbl.htm" file from the "run/nn-EnergyPlus-0" directory, the Outdoor Air Summary indeed shows 0 ach for Mechanical Ventilation (although it shows non-0 ach for Simple Ventilation - not sure what that is).

Then I edited the "out.idf" file from the "run/nn-EnergyPlusPreProcess-0" directory. Towards the end of the file, there is a section entitled "New objects created from ExpandObjects" (not sure what that is). In it are sections entitled ZoneHVAC:IdealLoadsAirSystem for each thermal zone of the model, and within these is a line named "Design Specification Outdoor Air Object Name". Towards the beginning of the same "out.idf" file are sections entitled DesignSpecification:OutdoorAir, and within these is a line named "Name".

So, I copied the name from the "Name" line of the DesignSpecification:OutdoorAir section to right before the comma on the "Design Specification Outdoor Air Object Name" line in the ZoneHVAC:IdealLoadsAirSystem section - correspondingly for each zone. That is a lot of copy and paste and requires some concentration, but it can be done. Then I ran this modified "out.idf" file straight through EnergyPlus, using the following:

cd 2-EnergyPlus-0

C:\Software\OpenStudio\share\openstudio\EnergyPlus-8-6-0\energyplus -w C:\Software\WeatherData\USA_TX_San.Antonio.Intl.AP.722530_TMY3.epw ..\1-EnergyPlusPreProcess-0\out.idf

cd ..

Now the "eplustbl.htm" file from the "run/nn-EnergyPlus-0" directory, shows non-0 ach in the Outdoor Air Summary for Mechanical Ventilation, and still the same non-0 ach for Simple Ventilation as before. The site and source Energy Use Intensity (MJ/m2) has increased as well.

Is this then how one can force Ideal Air Loads to include outdoor air?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 

Question Tools

2 followers

Stats

Asked: 2017-05-12 22:20:04 -0500

Seen: 332 times

Last updated: May 15 '17