Question-and-Answer Resource for the Building Energy Modeling Community
Get started with the Help page
Ask Your Question
4

Simulation runtime bloats when Transmittance Schedule assigned to shading surface

asked 2017-04-19 09:36:55 -0600

updated 2017-04-20 07:08:05 -0600

I assigned a transmittance schedule that is simple (0.7 in summer, 0.175 for winter) to some (79) shading surfaces in my model, in order to account for one deciduous tree that is shading my building.

I experienced a much (much!) longer runtime: from 2 minutes to 34 minutes.

Naively I expected that the transmittance schedule would only be used as a multiplier and wasn't expecting this.

Is this normal? Are there workarounds to not bloat the simulation runtime?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
4

answered 2017-04-19 09:52:36 -0600

updated 2017-04-20 02:04:01 -0600

The problem is that the Sky Diffuse Modeling Algorithm of ShadowCalculation is changed automatically by EnergyPlus.

** Warning ** GetShadowingInput: The shading transmittance for shading devices changes throughout the year. Choose DetailedSkyDiffuseModeling in the ShadowCalculation object to remove this warning.
 **   ~~~   ** Simulation has been reset to use DetailedSkyDiffuseModeling. Simulation continues.
 **   ~~~   ** Better accuracy may be gained by setting the Calculation Frequency to 1 in the ShadowCalculation object.

This happens in SolarShading.cc#L675.

There is a Github Issue that seems relevant here.


Shorten runtime?

I have set the Calculation Frequency to be 30 days (calc method set to AverageOverDaysInFrequency) instead of 7, runtime went down to 10 minutes.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 

Question Tools

2 followers

Stats

Asked: 2017-04-19 09:36:55 -0600

Seen: 89 times

Last updated: Apr 20