Question-and-Answer Resource for the Building Energy Modeling Community
Get started with the Help page
Ask Your Question
5

Coil:WaterHeating:Desuperheater methods not executing correctly

asked 2017-04-04 17:43:36 -0500

gokul gravatar image

updated 2017-08-05 07:35:05 -0500

Apologies in advance, if this is not a method error, but a script error. I was trying to add a Coil:WaterHeating:Desuperheater which collects heat from a Coil:Cooling:DX:SingleSpeed and rejects it to a WaterHeater:Mixed object, per the EnergyPlus IO reference for this object. This object is present in the Openstudio 1.14 sdk documentation.

I used user inputs to choose the WaterHeater and the CoolingCoil required, and used the addToHeatRejectionTarget method to add the OS:WaterHeater:Mixed as the rejection target, and the setHeatingSource method to add the required Coil:Cooling:DX:SingleSpeed as the heating source. The script executes properly (Apply Measures Now), as shown. The Water Inlet/Outlet Nodes have been attached from the OS:WaterHeater:mixed selected, and the Heating Source Name has also been assigned. However, when I run the simulation, I get a severe error saying that the Heating Source Name has not been translated into the idf (image).

This makes me believe that it's an OS internal issue. Is that right? Or is there another way/pseudo code through which this can be fixed? Or do I have to insert this object directly in the idf using an Eplus measure?

edit retag flag offensive close merge delete

Comments

1

You can make a temporary E+ measure for now to correct those two fields.

Adam Hilton gravatar imageAdam Hilton ( 2017-04-05 08:53:50 -0500 )edit

Thanks Adam, I'll do that.

gokul gravatar imagegokul ( 2017-04-05 09:41:29 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
3

answered 2017-04-05 08:52:59 -0500

Adam Hilton gravatar image

Forward translator problem. It's setting the dx coil by its' CoilSystem object (which is virtual) instead of the Coil object of the CoilSystem. The CoilSystem:Cooling:DX doesn't exist in the OpenStudio.idd, so it can't have a name saved in the *.osm which is why that field is left blank.

edit flag offensive delete link more

Comments

The same bug happens in Coil:Heating:Desuperheater as well. The HeatingSource field shows "CoilSystem:Cooling:DX" instead of "Coil:Cooling:DX:SingleSpeed", and name is missing as well. Hope this will be fixed.

mingo1214@gmail.com gravatar imagemingo1214@gmail.com ( 2018-06-30 17:31:15 -0500 )edit
4

answered 2019-04-04 16:12:29 -0500

This issue has been fixed in OpenStudio; the fix will be included in the upcoming OpenStudio 2.8.0 release.

edit flag offensive delete link more

Comments

Thanks! That it great news!

gokul gravatar imagegokul ( 2019-04-04 18:00:58 -0500 )edit
2

Credit goes to @Julien Marrec for fixing it.

shorowit gravatar imageshorowit ( 2019-04-05 07:08:32 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 



Question Tools

1 follower

Stats

Asked: 2017-04-04 17:43:36 -0500

Seen: 278 times

Last updated: Apr 04