Question-and-Answer Resource for the Building Energy Modeling Community
Get started with the Help page
Ask Your Question
1

CBECC-Com Detailed Geometry Surface Azimuth Errors!?

asked 2017-02-11 14:26:35 -0500

updated 2017-08-20 14:45:45 -0500

I have created several detailed geometries using both IESVE and SketchUp/OpenStudio for Title 24 simulation using CBECC-Com 2013 and 2016, and have hit dead ends with the following errors:

Error: Trig parameter out of range evaluating rule: Set DEFAULT ExtWall:RealAz (12:'ComponentAreas.rule' line 368) Error: Undefined data: left side of '+' evaluating rule: Set DEFAULT ExtWall:Az (12:'ComponentAreas.rule' line 405) Error: Undefined data: left side of '<' evaluating rule: Set DEFAULT ExtWall:TreeDescrip (12:'ComponentAreas.rule' line 427)

When going to the specified lines in the "componentareas.rule" file, it's quite obvious they are using the calculated azimuth angle for exterior surfaces (typically walls, I believe). And when looking at the file in the CBECC-Com interface, it's also clear that the azimuth angles are not being calculated for some (not all) surfaces. You can tell because the surface does not list the construction assembly assigned to it, which it usually does. And then double clicking that surfaces shows the two azimuth fields, that should be calculated, are blank.

I've checked to see if the polygons are non-planar, but those I checked were in fact planar. I don't know what else to check, but I'm hoping somebody has run into this and developed some kind of fix - either in the original geometry software or in the SDDxml file (ideally the latter so I don't lose the work I've put into my model).

Thanks in advance for any help!

edit retag flag offensive close merge delete

Comments

Could you post a snippet of the SDDXML where this error occurs? Just the opening and closing ExtWall portion.

pflaumingo gravatar imagepflaumingo ( 2017-02-15 12:24:59 -0500 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2017-02-15 05:04:13 -0500

Gurneet gravatar image

Hi Greg,

The error is due to the azimuth angle given in the openstudio. If you keep it 0 CBECC will be able to import the same without EXtWall error. You can always give the azimuth angle in CBECC tool itself.

Regards

edit flag offensive delete link more
0

answered 2017-02-16 19:57:33 -0500

See here for a response from CBECC-Com development team:

… the problem is related to a floating point precision problem in the source code that was associated with the 2016.2.1 release. Solution for this project in the 2016.2.1 release is to simply make a tiny adjustment to the Bldg:Az. I switched the Bldg:Az from 30 to 29.9 and the error disappears - modified project file attached….

edit flag offensive delete link more

Comments

@Greg Collins I recently ran into this on a large model (where BldgAz=338deg) as well, got the same answer as you did from support. Make a small change = problem solved. What is "interesting" is that I tested a bunch of different angles from 0 - 360, and it appears to be wildly random, and a small (~0.1) change in angle 'fixes' the issue....bewildering. Glad you're back in business!

dradair gravatar imagedradair ( 2017-02-17 08:33:05 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 



Question Tools

1 follower

Stats

Asked: 2017-02-11 14:26:35 -0500

Seen: 82 times

Last updated: Feb 16 '17