Question-and-Answer Resource for the Building Energy Modeling Community
Get s tarted with the Help page
Ask Your Question
2

Unknown error when using the OpenStudio Spreadsheet

asked 2017-01-05 03:50:24 -0500

Kingo gravatar image

I'm currently writting my master thesis on stochastic modelling and have been using the open studio spreadsheet for the purpose but when i came back to work after the holidays, it suddenly did'nt work anymore. It worked perfectly fine before Christmas.

Since i can't attach files (need 10 points o.o) i have pasted some bits that i hope makes sense.

Status log:

/var/www/rails/openstudio/lib/analysis/batch_run.rb failed with undefined method last' for nil:NilClass, /var/www/rails/openstudio/lib/analysis/r/cluster.rb:168:inblock in worker_init_finalize' /var/www/rails/openstudio/lib/analysis/r/cluster.rb:168:in map' /var/www/rails/openstudio/lib/analysis/r/cluster.rb:168:inworker_init_finalize' /var/www/rails/openstudio/lib/analysis/r/cluster.rb:181:

This one just goes on and on..

From RServe:

/opt/rbenv/versions/2.0.0-p481/lib/ruby/gems/2.0.0/gems/bundler-1.13.1/lib/bundler/source/git/git_proxy.rb:224:in allowed_in_path': The git source git://github.com/NREL/OpenStudio-workflow-gem.git is not yet checked out. Please runbundle install` before trying to start your application (Bundler::GitError)

I did try to update bundler and bundle install as it says but without luck. Still get the same error. I also tried with a fresh copy from the git repository which still did not work.

edit retag flag offensive close merge delete

Comments

1

I can replicate the problem and am working on a fix. Looks like an update to the Nokogiri gem is in conflict and was not version locked in the server. Will post when I have a fix. Sorry for the inconvenience.

BrianLBall gravatar image BrianLBall  ( 2017-01-05 11:07:28 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
3

answered 2017-01-05 15:05:05 -0500

If you are using AWS then update your OS Server Version to '1.21.4' in the spreadsheet. This uses OS version 1.13.2. If you are building your own Vagrant Boxes, then do a pull from Develop branch of OS Server and rebuild.

The Gemfile's in the Server have been version locked to the 1.6.8 Nokogiri gem.

I believe this is going to impact all older AMIs as well.

edit flag offensive delete link more

Comments

@BrianLBall Thanks that worked :)

I'm now getting an error with a measure. Do you by any chance know what this means:

"[10:13:27.2 INFO] Loading Measure from /mnt/openstudio/analysis_4dd0afc0-83b5-4ecf-98e0-fd5d37565009/measures/ChangeRoofThermalProperties/measure.rb [10:13:27.2 INFO] Iterating over arguments for workflow item 'change_roof_thermal_properties' [10:13:27.2 INFO] Setting argument value '__SKIP__' to 'false' [10:13:27.2 ERROR].......Failed with Could not find argument map in measure for '__SKIP__' with value 'false',....."

Kingo gravatar image Kingo  ( 2017-01-06 04:39:02 -0500 )edit

that usually means you are trying to set a measure argument that doesn't exist. I would double check your measure arguments for that measure in the spreadsheet and make sure they are all legit by comparing them to whats actually in the measure. Also, try using the measure in the OS app with the 'apply measures now' feature and see if you get the same error.

BrianLBall gravatar image BrianLBall  ( 2017-01-06 10:23:29 -0500 )edit

actually I think the problem is with your openstudio-analysis gem in the spreadsheet repo. In your Gemfile and Gemfile.lock, change the version to 0.4.5 and update your gems. (you might need to force nokogiri to 1.6.8.1 if you do bundle update).

BrianLBall gravatar image BrianLBall  ( 2017-01-06 13:14:38 -0500 )edit

I did that and updated my gems and now im getting an error in cmd when doing the rake run after selecting a project.

"Unable to parse spreadsheet ./projects/SingleZone.xlsx with version 0.4.2 due to error: Roo::HeaderRowNotFoundError

Kingo gravatar image Kingo  ( 2017-01-06 14:20:11 -0500 )edit

yeah, i had the error too while trying to get the gems correct. You might try recloning the repo into a new directory, make those changes and then do a 'bundle' and 'bundle update'. But once you get the right analysis gem in there that should clear that error up.

BrianLBall gravatar image BrianLBall  ( 2017-01-06 14:39:20 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 

Question Tools

1 follower

Stats

Asked: 2017-01-05 03:50:24 -0500

Seen: 177 times

Last updated: Jan 05 '17