Question-and-Answer Resource for the Building Energy Modeling Community
Get s tarted with the Help page
Ask Your Question
1

Extra surfaces created in IDF file but do not show up in Sketchup

asked 2016-11-30 12:20:18 -0500

updated 2016-11-30 13:03:14 -0500

Hi All,

I am having a strange issue with the geometry of my Energy Model. The model has 239 thermal zones. The geometry was created in sketchup/Openstudio and exported to IDF file format after intersecting and matching. After running the model, I realized that the total building area of the model was considerably higher than what I was expecting. Upon inspecting the model, I found that some extra (floor) surfaces were added in the IDF and hence the simulation was double-counting the areas of a few zones. These surfaces did not share the same name but had the same properties.

image description

This issue was observed for only few zones. These extra surface were not visualized when I tried opening the model in Sketchup/openstudio.

image description

The surface area of the floor selected in the above image is 93.62 sqm. (The image may not be very clear) Although this is the only floor surface in the zone, the zone area from the simulation is 187.24.

image description

I had to manually search for duplicate XYZ coordinates of surfaces from the same zones using a text editor to remove these surfaces. I am not sure if this is the most efficient way to deal with the issue. It would be great to know if someone else had any similar issues. If yes, could you please let me know the best way to deal with this situation?

Thank you, Raghu Sunnam

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
2

answered 2016-12-01 02:15:17 -0500

This is an issue when trying to use the Legacy OpenStudio plug-in with SketchUp 2016. According to @macumber on the Github issue posted HERE, this is something that changed within SketchUp and not the plug-in.

What I have done is use the same Legacy OpenStudio plug-in, but for a previous version of SketchUp (SketchUp 8, SketchUp 2014, etc.). That has worked fine without any issues.

I hope this helps,

Aaron

edit flag offensive delete link more

Comments

That is interesting. Thank you for pointing to this issue. I had created the original geometry using Legacyv1.0.13 and SketchUp 2015 before updating them both. I checked the initial run of the model and the areas issue was also in the initial run (when I used Sketchup 2015). I have a couple of follow-up questions:

  1. Do we use Sketchup 2014 or previous versions when working with Legacy OpenStudio plugin?

  2. In the issue that you pointed out, it seems that all surfaces and sub-surfaces were duplicated. In my model, only few surfaces were duplicated (but with unique names). Are they same?

rsunnam gravatar image rsunnam  ( 2016-12-01 09:55:23 -0500 )edit
1
  1. Yes, until this bug has been resolved in a new Legacy OpenStudio plugin, use SU 2014 or a previous version.
  2. Did you create the model in SU 2014 or earlier, then try to open the model in SU 2015 to add more zones? Maybe you only see a few duplicate surfaces because you only created a few new zones using SU 2015? The bug does create two surface objects where all input field values are the same except their names ("CEFF46" and "7A5FAB", according to your screen shot). These are essentially the same surface.
Aaron Boranian gravatar image Aaron Boranian  ( 2016-12-01 10:28:50 -0500 )edit

I created the entire model in SU2015 and then opened it in SU2016 for verifying the surfaces issue later. Regardless, I think your first answer is very useful to know. This issue added significant overhead to the project so working with SU2014 seems to be the best way forward. Thanks again for the insights! It is much appreciated.

  • Raghu
rsunnam gravatar image rsunnam  ( 2016-12-01 11:46:44 -0500 )edit
0

answered 2016-11-30 12:54:48 -0500

Ricardo GAllegos gravatar image

updated 2016-11-30 12:57:23 -0500

I have had this problem and I was told that there is not yet a plugin for SU that works with E+ 8.4 or 8.5. What I do is to create the model in E+ and then open in SU just to check geometry, but do not save it in su as idf. But my projects are smaller than yours.

edit flag offensive delete link more

Comments

Hi, I am currently using Legacy Openstudio v1.0.14 that works with E+ v8.4. Unfortunately, I cannot create the geometry in E+ for buildings of this size. Also, I worked with a few other models simultaneously but did not face this problem. Did you also have the same issue where 'ghost' surfaces with unique names were created but not visualized in Sketchup?

Thanks, Raghu

rsunnam gravatar image rsunnam  ( 2016-11-30 13:14:57 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 

Question Tools

1 follower

Stats

Asked: 2016-11-30 12:20:18 -0500

Seen: 224 times

Last updated: Dec 01 '16