Question-and-Answer Resource for the Building Energy Modeling Community
Get s tarted with the Help page
Ask Your Question
1

ERROR - Field [Construction Name] is required but was blank (Fixed Windows)

asked 2014-12-17 12:31:37 -0600

nfonner gravatar image

updated 2021-05-07 11:43:01 -0600

No matter where I assign the construction, the following errors occur. (Eg. At the building level, space type level, space level, or at the sub surface level.) I thought this error was explained before the move to Unmet hours, but I do not see any post with the same problem. This has happened in other models I have started, but not every time.

I have also hard coded the construction name in the .osm file using Notepad++. However, the idf .err file still shows the blank entry. It is almost as if the fixed window construction lookup (hierarchy) is not assigning the construction at run time.

Any help is greatly appreciated.


* Severe * IP: IDF line~1316 Error detected in Object=FENESTRATIONSURFACE:DETAILED, name=SUB SURFACE 11
* ~~~ * Field [Construction Name] is required but was blank
------------- IDF Context for following error/warning message:
------------- Note -- lines truncated at 300 characters, if necessary...
------------- 1329 FenestrationSurface:Detailed,
-------------indicated Name=Sub Surface 12
------------- Only last 3 lines before error line shown.....
------------- 1330 Sub Surface 12, !- Name
------------- 1331 Window, !- Surface Type
------------- 1332 , !- Construction Name

NEW INFO:
Apparently extra lines are being created in jumping from the SketchUp plugin to the OpenStudio model. These are called degenerate surfaces in the .err file. See attached for an example. Is this possibly a geometry corruption problem and not the Construction Name lookup?
image description

edit retag flag offensive close merge delete

Comments

I will add that the model includes adiabatic surfaces and interior windows. Both are assigned an appropriate construction at the surface/ subsurface level as required.

nfonner gravatar image nfonner  ( 2014-12-17 12:53:59 -0600 )edit

Ok. Smallest degree of an angle off on one line (the resulting generated wall overlapped between zones) in SketchUp plugin. This does not explain the image above since that is in a different area of the model. I started from scratch and do not see the issues any longer.

nfonner gravatar image nfonner  ( 2014-12-17 14:59:01 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2014-12-17 13:54:22 -0600

updated 2014-12-17 13:55:11 -0600

Sometimes SketchUp creates subsurfaces during the matching/intersecting process. Is Sub Surface 12 a window you created or one that SU created? If the latter you can try deleting the object from the OSM file manually, by searching for it in SU and deleting, or by using the Remove Orphan Subsurfaces plugin.

edit flag offensive delete link more

Comments

They were actually windows I created. I have no clue why this happens from time to time, but it may be the case where my drafting mistake above corrupted other aspects of the model.

nfonner gravatar image nfonner  ( 2014-12-17 15:09:17 -0600 )edit
1

answered 2014-12-17 15:07:40 -0600

nfonner gravatar image

Not a great answer, but I just started over.

The answer to the fixed window missing construction for now at least was to hard assign a construction, again, to each individual window after using the SketchUp plugin script to remove hard assigned constructions.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 

Question Tools

1 follower

Stats

Asked: 2014-12-17 12:31:37 -0600

Seen: 856 times

Last updated: Dec 17 '14