Question-and-Answer Resource for the Building Energy Modeling Community
Get s tarted with the Help page
Ask Your Question
2

How can I delete a Subsurface in sketchup, that is disappeared?

asked 2016-10-19 05:24:27 -0500

poppo92 gravatar image

updated 2020-01-26 11:47:50 -0500

I opened my OS model in SketchUp, and this message appeared to me:

Warning: Sub Surface 143 This sub surface was not in the same plane as its base surface. It has been automatically fixed.

Error: Sub Surface 143 This sub surface is not contained by its base surface, it cannot be drawn.

Very good. I just want to delete this subsurface, but it is not drawn in the model, so i cannot select it. If I use the Inpector, I can find it, but it's not possible to delete it. How can I do? I want to delete this subsurface because I'm sure that when I will run the simulation in OpenStudio, it will stop because of this error for sure.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
3

answered 2016-10-19 07:10:18 -0500

Carlos Vazquez gravatar image

updated 2016-10-22 09:49:20 -0500

This is what is called in openstudio as an "orphan subsurface". It is not shown in sketchup but it is in your *.osm file. Within the openstudio plugin in sketchup, go to Extensions; OpenStudio User Scripts; Alter or Add Model Elements; Remove OrphanSubsurfaces. The program will give you a message confirming that a subsurface has been removed. Save and close your model. When you re-open it again, the error message will not appear again. Let me know if it works. Another way to do it is to open your *.osm file in a text editor and delete the subsurface directly from your model script.

There is also a measure within openstudio to "Remove Orphan Objects and Unused Resources"

edit flag offensive delete link more

Comments

i did it, but it says " No orphan sub-surfces to remove"

poppo92 gravatar image poppo92  ( 2016-10-19 08:23:47 -0500 )edit
3

Then take note of the subsurface description. Close your model within sketch-up. Open the *.osm file in a text editor. And lookup for the orphan subsurface within the model. There might be thousands of lines so you have to be careful in what you delete. Find the subsurface and delete it. Save the file within your text editor, close it, and re-open it again in the sketchup plug-in.

Carlos Vazquez gravatar image Carlos Vazquez  ( 2016-10-19 08:36:25 -0500 )edit

You can also try running the OSM diagnostic script reporting measure from within the Sketchup plugin. This should remove orphaned subsurfaces, as well as other problems in geometry.

kramerica gravatar image kramerica  ( 2016-10-24 09:52:02 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 

Question Tools

2 followers

Stats

Asked: 2016-10-19 05:24:27 -0500

Seen: 1,835 times

Last updated: Oct 22 '16