Question-and-Answer Resource for the Building Energy Modeling Community
Get started with the Help page
Ask Your Question
1

openstudio-standards gem installation problem

asked 2016-08-03 10:22:43 -0500

dpud12's avatar

updated 2016-08-03 10:23:26 -0500

I am having a difficulty installing the openstudio-standards gem, see the command window screenshot for reference. When I build the gem, it says that I have built it successfully, however, when I go to install it, it says that I need to have a u:\ drive folder path specified. Has anyone seen this before? Thanks in advance for any help! image description

edit retag flag offensive close merge delete

Comments

@dpud12 If you run: echo %HOMEDRIVE% Do you see C: or U: ? At work, when I'm connected to the internal network, something IT thing changes my %HOMEDRIVE% from C: to U:, which in turn creates problems like this. I'm wondering if your network has something similar.

aparker's avatar aparker  ( 2016-08-04 09:49:03 -0500 )edit

Yep that is exactly what is occurring, thanks!

dpud12's avatar dpud12  ( 2016-08-04 10:18:03 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
5

answered 2016-08-04 09:58:13 -0500

updated 2016-08-04 09:59:06 -0500

If installing it to your %HOMEDRIVE% isn't working, try this:

  1. Make an Environment Variable called GEM_PATH with the Value C:\Ruby200-x64\lib\ruby\gems\2.0.0

NOTE this does not point to your Home directory, but your Ruby installation

  1. Download the source code or clone the source code using Git.
  2. In a command prompt, navigate to the openstudio-standards/openstudio-standards directory of the source code.
  3. gem build openstudio-standards.gemspec ENTER to build the gem.
  4. gem install openstudio-standards-0.1.4.gem ENTER to install the gem. NOTE: You may get a warning message about the path in this step. Ignore this message.
edit flag offensive delete link more

Comments

@aparker Thanks so much, this worked wonderfully!

dpud12's avatar dpud12  ( 2016-08-04 10:18:32 -0500 )edit

One additional step that I had to do was to create an Environment Variable named HOME with the Value: C:\ to get the measure to be recognized properly in the OpenStudio GUI

dpud12's avatar dpud12  ( 2016-08-04 10:37:27 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Training Workshops

Careers

Question Tools

1 follower

Stats

Asked: 2016-08-03 10:22:43 -0500

Seen: 616 times

Last updated: Aug 04 '16