Question-and-Answer Resource for the Building Energy Modeling Community
Get s tarted with the Help page
Ask Your Question
1

Problem with Surface matching measure

asked 2016-05-23 16:03:59 -0500

Morteza gravatar image

I tried to use surface matching measure for my model per David Goldwasser recommendation, but before the execution of the measure encountered following error: image description image description

Your help would be greatly appreciated!

edit retag flag offensive close merge delete

Comments

Hello, it'd be helpful if you could copy paste the entire error log you're getting.

Julien Marrec gravatar image Julien Marrec  ( 2016-05-24 00:50:42 -0500 )edit

Also @Morteza please always tag your question with the software you're using.

MatthewSteen gravatar image MatthewSteen  ( 2016-05-24 10:30:22 -0500 )edit

It looks like the intersect method in OpenStudio hitting a bug.

[BUG] Segmentation fault

If you send your OSM file to OpenStudio@NREL.gov we can try to figure out what is happening.

@macumber, any ideas.

David Goldwasser gravatar image David Goldwasser  ( 2016-05-24 11:58:37 -0500 )edit

I am using OpenStudio 1.11.0 Build Number: 4313b0e0d9.

In this model, a ‘subsurface’ was surrounded by a single larger surface by more than two edges. After I divided this surface in two and re used the surface matching in OpenStudio encountered no error and surface matching was successful.

Morteza gravatar image Morteza  ( 2016-05-24 12:23:43 -0500 )edit

@Morteza, thanks for the additional information.

David Goldwasser gravatar image David Goldwasser  ( 2016-05-24 12:38:54 -0500 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2016-05-26 10:20:31 -0500

@Morteza, there is an existing issue related to the OpenStudio intersect method. You seem to be hitting that. I was able to reproduce it with the model you sent, but I was also able to get it to run without hitting this error. I didn't do anything different one time vs. another. I'll email that file back to you. It is a 1.11.3 file vs. 1.11.0. Space 101 needs some minor repair, you need to re-draw an edge in SketchUp to crease surfaces to close to holes in the exterior roof surfaces, small glitch in the intersect.

edit flag offensive delete link more

Comments

@David Goldwasser, Thank you very much for your help, I used OpenStudio 1.11.3 with new intersect measure, and did not encounter any error.

Morteza gravatar image Morteza  ( 2016-05-26 12:21:00 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 

Question Tools

1 follower

Stats

Asked: 2016-05-23 16:03:59 -0500

Seen: 401 times

Last updated: May 26 '16