Question-and-Answer Resource for the Building Energy Modeling Community
Get s tarted with the Help page
Ask Your Question
7

Wall flying every where

asked 2014-11-29 03:20:48 -0500

devonqian gravatar image

updated 2014-12-07 16:56:49 -0500

image descriptionHi, I tried to do the drawing in the thermal zones. Everything works find until I added the windows on the wall, and then the walls fly everywhere. Is there anybody have the same problem as I am having? And anyone know how to fix it? Thank you so much.

edit retag flag offensive close merge delete

Comments

Which software are you using?

Jamie Bull gravatar image Jamie Bull  ( 2014-11-29 05:22:26 -0500 )edit

I am using SketchUp Openstudio Plug-in

devonqian gravatar image devonqian  ( 2014-12-01 23:09:10 -0500 )edit

Can you provide a few more details on how you are creating the windows, and what specifically is happening. Are the windows floating instead of attached to the base surfaces, or is it something else? Also does this happen immediately, or after you close and re-open the model.

David Goldwasser gravatar image David Goldwasser  ( 2014-12-02 09:40:50 -0500 )edit

Before I re-open the model, everything looks good. But after I re-opened it, the walls were everywhere. This issue only happens on those surfaces which I added the windows.

devonqian gravatar image devonqian  ( 2014-12-03 02:45:33 -0500 )edit

Does the error dialog show anything? You may also want to try the diagnostic script. A screen shot may still help to understand where the surfaces are going.

David Goldwasser gravatar image David Goldwasser  ( 2014-12-03 08:47:51 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
14

answered 2014-12-08 15:38:58 -0500

updated 2015-02-26 14:32:40 -0500

@devonqian I am sorry for these problems, I know they are very frustrating to deal with. The error that caused this to happen actually occurred during your first session, it was only when you opened the file that you saw the issue. Most likely, it was something like a bad undo operation or some geometry error that caused the plugin to stop working. If you work with the Ruby console open you will see these errors pop up right when they occur. You can then close the plugin and reopen you model with minimal damage. Also, it is a good practice to save multiple versions of your OSM as you work.

UPDATE

Turns out that this error is due to a SketchUp API issue:

http://sketchucation.com/forums/viewt...

I've filed this issue but won't be able to fully address until this is fixed in SketchUp. In the meantime, when editing your model only change the active group being edited one level at a time. Changing multiple levels at a time (which is possible by double clicking into another group while already inside of another one or by using the outliner) can cause this issue.

edit flag offensive delete link more

Comments

That's good to know. Thanks for sharing some valuable insight!

Enrique gravatar image Enrique  ( 2014-12-08 16:01:51 -0500 )edit

OK. Thank you so much. I will go and check that.

devonqian gravatar image devonqian  ( 2014-12-08 16:41:04 -0500 )edit

"If you work with the Ruby console open you will see these errors pop up right when they occur. You can then close the plugin and reopen you model with minimal damage." - good advice, thanks @macumber.

MatthewSteen gravatar image MatthewSteen  ( 2014-12-08 17:23:53 -0500 )edit

I am going to do some work to try to make these errors more apparent when they occur (by popping up a message box). However, it will probably be a good idea to keep an eye on the SketchUp console as well. Finally, if you ever see something that looks wrong it is a good idea to close SketchUp and restart it to clear any error that occurred.

macumber gravatar image macumber  ( 2014-12-09 09:12:48 -0500 )edit
4

answered 2015-01-20 18:19:35 -0500

We've been having problems similar to the image shown in this post. They tend to happen while we are drawing in windows or subsurfaces. Sometimes when we save and close, then reopen the file, windows and walls are misplaced, inverted, or simply missing.

By sheer rote, we realized that we can avoid this problem by double clicking out of a space before double clicking into the next space:

When drawing the windows, it is necessary to double-click to select the space, otherwise you will just be drawing a SketchUp surface. In order to save time, we were double-clicking on the next space we wanted to draw a window in while the previous space was still selected. I noticed that after operations where we were doing this frequently, the wall flying problem almost always occurred, so I tried double-clicking out of the space between each space change.

Since implementing this method we have had no issues with flying walls.

Unfortunately I cannot offer insight into how to repair a file which has flown walls. We've been keeping backups of our file every 15 minutes or so because when something goes wrong, we usually cannot fix it. You'll have to go back to the file without the windows and remember to deselect the space you have selected before selecting the next space.

edit flag offensive delete link more

Comments

Thank you for your help. I actually re-drawed it, and the problem had been solved.

devonqian gravatar image devonqian  ( 2015-01-20 19:59:10 -0500 )edit

Thanks @mgoldberg@westernallied.com">@mgoldberg@westernallied.com that is a very helpful insight, I will see if I can reproduce this issue the way you describe!

macumber gravatar image macumber  ( 2015-01-20 21:04:29 -0500 )edit

Agreed, thanks! I was able to re-produce this and filed an issue.

David Goldwasser gravatar image David Goldwasser  ( 2015-01-21 00:52:16 -0500 )edit

@Neal Kruis Robot Alert

aparker gravatar image aparker  ( 2015-01-24 08:20:38 -0500 )edit

@aparker I'm not sure this is a robot, but it certainly wasn't an answer. I've converted it to a comment. In the future, if you do come a cross a robot post, just flag it as offensive. This will notify me sooner about any problems.

Neal Kruis gravatar image Neal Kruis  ( 2015-01-24 14:34:40 -0500 )edit
2

answered 2014-12-08 10:33:53 -0500

Enrique gravatar image

updated 2015-02-28 05:36:22 -0500

Well I think the quickest way to fix your problem is to double click into a specific zone so that you can edit the geometry. Then select the entire detached surfaces per zone. Next use the move tool to move your selected surfaces an place them exactly where they should be on the specific zone. You might want to use the Hide Rest of Model Icon to isolate the specific zone you are working on.

Please let me know if you need more clarification on how to do this and i can probably put something together for you to give more detail instructions. I think this might be the easiest way to correct your issue rather than redo any of the geometry.

Also I have only had this type of issue and know of others who have only seen this issue when drawing windows into a zone on an individual basis. I am not sure if you are drawing each window individually into each zone but if you are I really recommended projecting the SketchUp geometry to create windows. Its not only faster but you avoid a lot of geometry frustrations.

edit flag offensive delete link more

Comments

OK. I will try it. Thank you so much.

devonqian gravatar image devonqian  ( 2014-12-08 16:40:12 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 

Question Tools

1 follower

Stats

Asked: 2014-11-29 03:20:48 -0500

Seen: 469 times

Last updated: Feb 28 '15