Question-and-Answer Resource for the Building Energy Modeling Community
Get s tarted with the Help page
Ask Your Question
3

OpenStudio Simulation Time

asked 2016-03-16 09:22:24 -0500

Pranav gravatar image

updated 2016-03-18 00:19:42 -0500

Hello,

My model consists of a fairly complex WSHP system with boilers and cooling towers. 40+ spaces are served by WSHPs. The model also has daylighting in many spaces. It takes approx. 18 minutes for the simulation to complete. The simulation jumps to "Processed 1 base script and 2 merged scripts" fairly quickly (approx. 62% progress). Then it takes a long time to go to the next step. Most of the time is taken by E+ while sizing systems ("Calculating System sizing") and calculating daylighting factors (I think based on the progress shown in OS). Does that seem reasonable? I am not used to seeing a simulation take so long, so want to share this and get feedback.

The simulation snapshots are saved in the file upload section.C:\fakepath\OS-3.png(/upfiles/14581392437980734.png) C:\fakepath\OS-1.png(/upfiles/1458139202950102.png)

I found one thing. When I add the E+ measure for the utility cost calculation (Tariff Selection Time and Date Dependent with Maximum Demand Charge), the simulation takes a lot more time. See image 1 - only 5 minutes compared to 18 minutes in image 2. It's surprising, but that's what's happening!

Pranav

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
3

answered 2016-03-16 10:18:19 -0500

NickC gravatar image

updated 2016-03-16 10:34:32 -0500

Hello P, here are some other steps I have taken previously to reduce simulation time. Not certain which ones would be applicable to your simulation so I suggest doing some testing to confirm that the desired result doesn't change appreciably when you reduce the simulation time. I'd also suggest thinking about how accurate the model must be before reducing simulation time. Good luck! -N

Under the simulations tab (blue arrow) you can:

  1. reduce the number of timesteps per hour (red arrow)
  2. reduce the run range (green arrow); perhaps just run a selection of days/weeks during each season C:\fakepath\Menubar_and_Untitled.jpg

Other possibilities:

  1. don't run simulation over the entire year (red arrow) and only run for sizing days (green arrow)
  2. take the sized HVAC parameters, input them into your model (i.e. hard-size everything), and then turn OFF sizing days (green arrow)
  3. change the solar calculation type to "minimal shadowing" (orange arrow); check here to see if this assumption makes sense C:\fakepath\Untitled.jpg
edit flag offensive delete link more
3

answered 2016-03-16 09:40:55 -0500

@Pranav, first the bad news: 18 minutes is reasonable for large models when doing daylighting calcs. I can't tell for sure without time-profiling your model through a debug build, but I suspect that this is what's happening. Now the good news: the EnergyPlus version update due at the end of the month (V8.5) uses a new data structure to speed up daylighting calcs significantly. If you can't wait that long, you can download a pre-release version from GitHub (https://github.com/NREL/EnergyPlus/re...).

edit flag offensive delete link more

Comments

Thank you, Amir.

Pranav gravatar image Pranav  ( 2016-03-16 09:43:24 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 

Question Tools

Stats

Asked: 2016-03-16 09:22:24 -0500

Seen: 539 times

Last updated: Mar 18 '16