Question-and-Answer Resource for the Building Energy Modeling Community
Get s tarted with the Help page
Ask Your Question
1

rogue shading surface

asked 2016-03-05 22:01:22 -0600

mattkoch gravatar image

updated 2016-03-06 13:24:17 -0600

Hello,

I am using SketchUp 2016 with OpenStudio plugin 1.10.0. I think I "lost" a shading surface somewhere, and I cannot find it with Inspector, Search Surfaces or OSM Diagnostic Script. When launching OpenStudio/EnergyPlus from within the plugin, eplusout.err contains the following lines:

* Severe * IP: IDF line~14639 Object=SHADING:BUILDING:DETAILED, name=SHADING SURFACE 7, Required Field=[Vertex 1 X-coordinate] was blank. * Severe * IP: IDF line~14639 Object=SHADING:BUILDING:DETAILED, name=SHADING SURFACE 7, Required Field=[Vertex 1 Y-coordinate] was blank. * Severe * IP: IDF line~14639 Object=SHADING:BUILDING:DETAILED, name=SHADING SURFACE 7, Required Field=[Vertex 1 Z-coordinate] was blank. * Severe * IP: IDF line~14639 Object=SHADING:BUILDING:DETAILED, name=SHADING SURFACE 7, Required Field=[Vertex 2 X-coordinate] was blank. * Severe * IP: IDF line~14639 Object=SHADING:BUILDING:DETAILED, name=SHADING SURFACE 7, Required Field=[Vertex 2 Y-coordinate] was blank. * Severe * IP: IDF line~14639 Object=SHADING:BUILDING:DETAILED, name=SHADING SURFACE 7, Required Field=[Vertex 2 Z-coordinate] was blank. * Severe * IP: IDF line~14639 Object=SHADING:BUILDING:DETAILED, name=SHADING SURFACE 7, Required Field=[Vertex 3 X-coordinate] was blank. * Severe * IP: IDF line~14639 Object=SHADING:BUILDING:DETAILED, name=SHADING SURFACE 7, Required Field=[Vertex 3 Y-coordinate] was blank. * Severe * IP: IDF line~14639 Object=SHADING:BUILDING:DETAILED, name=SHADING SURFACE 7, Required Field=[Vertex 3 Z-coordinate] was blank.

The same can be found in eplusout.audit. And in.idf contains the following lines:

Shading:Building:Detailed,
  Shading Surface 7,                      !- Name
  ,                                       !- Transmittance Schedule Name
  ;                                       !- Number of Vertices

This does indeed appear to be an empty surface, when compared to other shading surfaces in in.idf. EnergyPlus will not continue unless this error is resolved. Is there a plugin/ruby user script that can find this rogue shading surface in the .OSM file and delete it?

Thanks,

Matt Koch mattkoch@scitex.us

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2016-03-06 13:30:55 -0600

You could try running the remove_orphan_objects_and_unused_resources measure from OpenStudio. If that doesn't work you can open the OSM in a text editor, search for the object, and then delete it. The second option is not generally recommended and should be done very carefully.

edit flag offensive delete link more

Comments

Thank you Sir. I ended up editing the OSM file. The Shading Surface had no Shading Surface Group associated with it. Instead of outright deleting the surface (which might have worked), I made its dimensions big and assigned it to one of the existing Shading Surface Groups (long hex format number). Then it showed up nicely in the SketchUp plugin, and I could edit the Shading Surface Group and delete the Shading Surface from there. This solved the problem. Also, thank you for pointing out the measure - I was unaware of it. This may well have worked as well here.

mattkoch gravatar image mattkoch  ( 2016-03-06 13:58:55 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 

Question Tools

Stats

Asked: 2016-03-05 22:01:22 -0600

Seen: 140 times

Last updated: Mar 06 '16