Question-and-Answer Resource for the Building Energy Modeling Community
Get started with the Help page
Ask Your Question

Radiant Ceiling System

asked 2016-02-03 15:05:36 -0600

Phil's avatar

updated 2016-02-03 15:22:40 -0600

Hi, I am trying to implement a radiant ceiling system to my OpenStudio (V1.9.5) model. As shown in many tutorials I created an internal source construction, applied it to the surface and used the low temperature radiant var flow for the thermal zone. As long as applied for my first floor it works, but as soon as I try to apply it to the second floor I get the following error:

* Severe * Surface SURFACE 30 is referenced by more than one radiant system--this is not allowed * Severe * Interzone surface SURFACE 55 is referenced by more than one radiant system--this is not allowed

I compared two .idf files, one in which I used a BCL measure to apply a radiant floor system and one where I assigned the internal source construction by myself. What is striking is that in the model I applied the radiant ceiling system the flow fraction is shared (shown below). Do you know why this happens? I did not make this selection in my OpenStudio model. And why does the BCL measure apply an internal construction for each surface, is that necessary?

Thank you, Phil

ZoneHVAC:LowTemperatureRadiant:SurfaceGroup, Low Temp Radiant Var Flow 4Ceilings, !- Name Surface 55, !- Surface Name 1 0.5, !- Flow Fraction for Surface 1 Surface 60, !- Surface Name 2 0.5; !- Flow Fraction for Surface 2

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2016-02-03 20:46:32 -0600

updated 2016-02-03 21:01:14 -0600

To answer the second part of your question first: When OpenStudio creates the EnergyPlus idf, it translates the OS:ZoneHVAC:LowTemperatureRadiant:VariableFlow object input field 'Radiant Surface Type' into the EnergyPlus ZoneHVAC:LowTemperatureRadiant:VariableFlow object input field 'Surface Name or Radiant Surface Group Name', in order to spare the user the tedium of listing all the associated radiant surfaces by name. If you read the input description for the EnergyPlus field linked above, you'll note that the surface group also defines the fraction of flow going to each surface. This translation happens here.

So why are your surfaces being referenced by more than one radiant system? I'm willing to bet that whatever measure you used applied an internal source construction not only to the ceilings of your ground floor spaces, but also to the matched floor surface of the space above (so EnergyPlus won't throw an error about matched surfaces with differing constructions). Which should be fine if you specify 'Ceilings' for 'Radiant Surface Type', which should just pick up the ceiling surfaces to add to the SurfaceGroup.

Except there's a problem: as I noted a while back (almost a year now!), there is a bug in the translation of the 'Surface Type' input, where when choosing 'Ceilings' for radiant systems serving zones whose floors also have internal source constructions applied, the floors are erroneously added to the surface group! So, if you have stacked zones with radiant ceilings in each zone, you end up with the upper zone having a SurfaceGroup that contains that zone's ceiling AND floor. But that floor is also the outside boundary condition of the lower zone's ceiling, which is the radiant surface for the lower zone's radiant system. Since matched interior surfaces aren't really seen by EnergyPlus as two surfaces, but as mirrored instances of the same construction, you end up with a surface being referenced by two radiant systems.

So what do you do about it? Well, until the translation bug is fixed, not much. There is no method in the OpenStudio API for removing surfaces from the radiant system surface list (that I know of). I suppose an EnergyPlus measure could do it, but that would be tricky. When I ran into this problem, I ended up making plenums above the spaces, so that the spaces above would have floors without internal source constructions. If this isn't an option for you, you might have to get creative, or directly edit the IDF.

edit flag offensive delete link more


Thank you very much for your comprehensive explanation. I would like to try your suggestion with the plenum. How can I do that? Editing the IDF would mean that I havw to leave OS for my future steps and I would like to omit that.

Phil's avatar Phil  ( 2016-02-03 22:02:19 -0600 )edit

Sorry for the late response. Basically in the sketchup plugin you can lower the ceiling height of your room (say, from 9' to 7') and create a new space 2' high above your now shortened space. You'll also want to create and assign a 'Plenum' space type to the plenum space, and an unconditioned zone for it, too. Then you can match surfaces, and even though your plenum space's 'floor' will be assigned an internal source construction, since the plenum zone doesn't have a radiant system, the radiant surface will only be referenced by the lower zone's system.

ericringold's avatar ericringold  ( 2016-02-14 12:47:55 -0600 )edit

Thank you very much. I will try that.

Phil's avatar Phil  ( 2016-02-14 17:42:34 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2016-02-03 15:05:36 -0600

Seen: 704 times

Last updated: Feb 03 '16