Question-and-Answer Resource for the Building Energy Modeling Community
Get s tarted with the Help page
Ask Your Question
1

Schedule:Constant

asked 2016-02-03 09:48:29 -0600

Phil gravatar image

updated 2017-08-07 13:49:49 -0600

Hi, I ran into following warning:

* Warning * ProcessScheduleInput: Schedule:Constant="ALWAYS_ON", Blank Schedule Type Limits Name input -- will not be validated.

As long as I don't use any equipment which needs the Always On Schedule nothing severe happens. But if I for example add a HVAC System were some fans use the constant schedule I get the error message below. I already tried different approaches (tried to change .osm code) but I couldn't find any solution yet. Any idea what could help?

Thank you, Phil

image description

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
1

answered 2016-02-03 11:58:58 -0600

The initial warning you see about the "ALWAYS_ON" schedule is because the "Schedule Type" input field of the Constant Schedule object is blank. This input field references a Schedule Type Limits object elsewhere in the model. The "OnOff" Schedule Type option would be best for a constant "ALWAYS_ON" schedule.

Looking at your error file screen shot, your simulation is crashing because the Plant Equipment Operation Schemes object named "Service Hot Water Loop Operation Schemes" doesn't have a schedule input on line 30912. This field should match the name of a Schedule object elsewhere in the model.

Are you using OpenStudio to create this model? You mentioned that you had tried to change .osm code. OpenStudio should automatically create Schedule Type Limits objects depending upon Schedule objects in the model. When you create a new schedule, OpenStudio asks you to select the schedule type (see image below).

image description

Creating new schedule in OpenStudio

OpenStudio should also automatically create Plant Equipment Operation Schemes objects depending upon plant equipment assigned to the different loops in the model (can reference other related questions HERE and HERE). If you are using OpenStudio, which version are you using?

edit flag offensive delete link more

Comments

I am using OpenStudio(Version 1.9.5). Openstudio made this schedule automatically and since it is a constant schedule I cannot change it in the schedule settings. There are also 4 drop-down menus which are empty in the PlantLoop settings (I cannot select anything there). I created a OnOff schedule for my HPWH but I cannot find any equipment which uses the mentioned schedule in the errors.

Phil gravatar image Phil  ( 2016-02-03 12:38:38 -0600 )edit

I also have 4 drop-down menus related to Plant Loop settings with nothing to select. Since Plant Equipment Operation Schemes are created based upon equipment on the plant loop, please include a screen shot of your Hot Water Loop to make it easier to find what's going on. There is a Git Hub issue HERE for component placement issues.

This seems to be more of an OpenStudio GUI issue, so I'll tag @David Goldwasser, @macumber, @Kyle Benne, and @aparker for help.

Aaron Boranian gravatar image Aaron Boranian  ( 2016-02-03 13:18:39 -0600 )edit

I put the screenshot into an answer. I just saw that even my newly drawn models from the SketchUp plugin have the same error. And there is no equipment assigned yet.

Thank you

Phil gravatar image Phil  ( 2016-02-03 16:04:12 -0600 )edit

That is very strange. It may be worth a shot to install v1.10.0 or v1.9.0 and try again. I personally avoid the pre-release versions that end in something other than "0". If you install v1.10.0, the OpenStudio application will ask to automatically update your OSM file.

Aaron Boranian gravatar image Aaron Boranian  ( 2016-02-04 09:00:41 -0600 )edit
1

I installed version 1.10.0 now, it actually got worse. Simulating the same files with the the mentioned error leads to following warnings:

* Warning * ProcessScheduleInput: Schedule:Constant="ALWAYS_ON", Blank Schedule Type Limits Name input -- will not be validated. * Warning * ProcessScheduleInput: Schedule:Constant="ALWAYS ON DISCRETE", Blank Schedule Type Limits Name input -- will not be validated. * Warning * ProcessScheduleInput: Schedule:Constant="ALWAYS OFF DISCRETE", Blank Schedule Type Limits Name input -- will not be validated. * Warning * ProcessScheduleInput:

Phil gravatar image Phil  ( 2016-02-04 10:39:41 -0600 )edit
1

answered 2016-02-03 16:07:28 -0600

Phil gravatar image

Screenshot from the Service Hot Water Loop. The hot water storage is connected to a HPWH in a thermal zone. C:\fakepath\Service hot water loop.png

edit flag offensive delete link more
0

answered 2017-03-03 12:52:49 -0600

Gjko gravatar image

I have a similiar problem with the same warning

** Warning ** ProcessScheduleInput: Schedule:Constant="ALWAYS OFF DISCRETE", Blank Schedule Type Limits Name input -- will not be validated.
   ** Warning ** ProcessScheduleInput: Schedule:Constant="ALWAYS ON CONTINUOUS", Blank Schedule Type Limits Name input -- will not be validated.

The thing is that I haven't created these schedules in OpenStudio and if I open the openstudio model in text editor they aren't there.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 

Question Tools

2 followers

Stats

Asked: 2016-02-03 09:48:29 -0600

Seen: 1,921 times

Last updated: Mar 03 '17