Question-and-Answer Resource for the Building Energy Modeling Community
Get s tarted with the Help page
Ask Your Question
4

Creating Custom Meters in OpenStudio

asked 2016-01-12 13:25:55 -0500

Alex Bennett gravatar image

updated 2017-08-05 13:02:50 -0500

I am looking for a way to create a custom meter to meter the residential and commercial components of a building separately. I have seen ways to do this in EnergyPlus but have not found options to do it in OpenStudio or any Ruby measures that can do it. Is there a way to do this in OpenStudio?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
3

answered 2016-01-13 11:15:53 -0500

updated 2016-01-13 12:57:31 -0500

This measure can be used to add a meter to an OpenStudio model.

edit flag offensive delete link more

Comments

Thanks for your response! This works well at creating meters but I am having issues with combining multiple meters into one. For example I want to have 3 different thermal zones all under one meter. Using the AddMeter measure I am only able to create three separate meters, is it possible to make them as one?

Alex Bennett gravatar image Alex Bennett  ( 2016-01-13 13:48:56 -0500 )edit
1

For that you want to create a CustomMeter. This object is not currently in the OpenStudio Model API so you will have to create it using an EnergyPlus measure.

macumber gravatar image macumber  ( 2016-01-13 14:35:48 -0500 )edit
1

answered 2019-10-31 19:28:23 -0500

The 'Custom Meter' Openstudio Measure on BCL does this. You define the variables or meters you want to include in a .csv file and pass the file path as an argument to the measure.

edit flag offensive delete link more

Comments

Is this measure still being supported? I added it from the BCL it to a model in OS V2.9.1, and none of the input fields show up in the measure tab.

nsimhai gravatar image nsimhai  ( 2020-08-07 16:43:10 -0500 )edit

this appears to be a bug in the measure. I'll put in a support issue for it.

mdahlhausen gravatar image mdahlhausen  ( 2020-08-24 13:41:23 -0500 )edit

@mdahlhausen Was this ever corrected? I just opened the measure I downloaded from the BCl and had the same problem with non of the user inputs showing up. Any update or advice for a work around would be greatly appreciated.

stanman gravatar image stanman  ( 2021-03-31 14:43:35 -0500 )edit

the measure is updated on GitHub - it needed a bit of refactoring to handle the newer OpenStudio versions

mdahlhausen gravatar image mdahlhausen  ( 2021-04-06 15:30:10 -0500 )edit

@mdahlhausen I have been trying to get the 'Custom Meter' measure working on OpenStudio 1.2.0 (SDK 3.2.0) but my simulation always fails with "No file found at file path ..." for my .csv, no matter what I try. Do you have any insight on this issue? Thanks

mechyai gravatar image mechyai  ( 2021-08-15 22:57:48 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 

Question Tools

1 follower

Stats

Asked: 2016-01-12 13:25:55 -0500

Seen: 706 times

Last updated: Oct 31 '19