Question-and-Answer Resource for the Building Energy Modeling Community
Get s tarted with the Help page
Ask Your Question
1

OpenStudio 1.10 plugin not showing in Sketchup 2016

asked 2016-01-06 08:39:44 -0500

wangh gravatar image

I used OS 1.09 32 bit w/ Sketchup 2015 Make previously. Then I uninstalled them and installed OS 1.10 and Sketchup 2016 Make both in 64bit. However, when I open stetchup, it will only show Welcome to OpenStudio Sketchup Plug-in... window and when I click either Yes, No or Cancel, the window disappear but the OS plugin is not showing. I tried to reinstall OS or Sketchup and restart and non worked...

edit retag flag offensive close merge delete

Comments

Is it possible that the OpenStudio toolbars are just hidden? If you go to the View/Toolbars dialog do you see toolbars for "OpenStudio Render Toolbars" and "OpenStudio Tools". If so make sure both of those are checked. Also do you see "OpenStudio" and "OpenStudio User Scripts" under the "Extensions menu?

David Goldwasser gravatar image David Goldwasser  ( 2016-01-06 09:50:11 -0500 )edit

It seems like the OpenStudio plug-in is not being selected initially in some cases. Your fix is correct, go into the Extensions window and make sure that it is selected.

macumber gravatar image macumber  ( 2016-01-06 11:33:08 -0500 )edit

I am having issue with the installation - and didn't want to start a new thread unnecessarily. I have installed OS v1.10, and it opens fine. I go to open Sketchup'16 and it brings up the yes/no/cancel box above. Without clicking anything, I get a new error:

dradair gravatar image dradair  ( 2016-02-15 16:25:15 -0500 )edit

Error Loading File C:/ProgramData/SketchUp/SketchUp 2016/SketchUp/Plugins/OpenStudio/Startup.rb Error: #<errno::einval: invalid="" argument="" -="" c:="" users="" darica~1="" appdata="" local="" temp="" sefaira="" c:="" program="" files="" openstudio="" 1.10.0="" ruby="" openstudio.rb=""> C:/Users/DARICA~1/AppData/Local/Temp/Sefaira/sfs_code/Sefaira/lib/pathname.rb:341:in lstat' C:/Users/DARICA~1/AppData/Local/Temp/Sefaira/sfs_code/Sefaira/lib/pathname.rb:341:inrealpath' C:/Program Files/OpenStudio 1.10.0/Ruby/openstudio.rb:30:in `<top (required)&gt;'="" c:="" program="" files="" sketchup="" sketchup="" 2016="" tools="" rubystdlib="" rubygems="" core_ext="" kernel_require.rb<="" p="">

dradair gravatar image dradair  ( 2016-02-15 16:25:20 -0500 )edit

Answer - I have zero idea. but after disabling and reenabling Sefaira and OS....about 10 times...it ran/loads.

dradair gravatar image dradair  ( 2016-02-15 16:38:56 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2016-01-06 10:07:05 -0500

wangh gravatar image

updated 2016-01-06 10:07:13 -0500

Thanks. Acutally I found out is not activated somehow. Window-Peferences-Extention. OS plugin is not checked...

edit flag offensive delete link more
0

answered 2016-03-03 20:51:00 -0500

Sketchup must be installed on your C:\ drive using Windows 10. Open studio looks at the path the Sketchup program files are stored. The path that the developers specified cannot be user defined so the plugin doesn't know where to look.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 

Question Tools

Stats

Asked: 2016-01-06 08:39:44 -0500

Seen: 1,765 times

Last updated: Jan 06 '16