Question-and-Answer Resource for the Building Energy Modeling Community
Get s tarted with the Help page
Ask Your Question
3

How to repair a broken Measure

asked 2015-11-29 10:27:08 -0500

Gurneet gravatar image

updated 2015-11-30 03:11:16 -0500

I downloaded the "Add PSZ-HP to all zones" measures from BCL, it is showing a broken script kind of red icon besides it. When i try to add the measure it says "Failed to compute arguments for the measure" Unable to locate primary Ruby Script path. It also doesnot show in the measures window. But when i run the model it throws an error "Measure "Add PSZ-HP to all zones" is missing its measure.rb file, update this measure and try again.

I tried downloading it again from BCL, however not able to as it is greyed out i.e. not allowing me to re-download. Kindly suggest how to update the measure or solution to remove the error at runtime.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-11-30 03:10:58 -0500

That's a measure of mine, and it's working for me, not sure why it wasn't working on your end. I just reuploaded a new version to the BCL here. Can you try again and let me know if you still have problems?

Otherwise, you can always find the measure on my personal Github repository here.

edit flag offensive delete link more

Comments

Thanks for your reply. I was able to solve the issue by downloading the component directly from BCL and the replacing the file in C:\Users\Name\BCL folder. Now it is working, I believe the issue was the .rb file was in a subfolder so it was not able to locate the same, so I copied the same in root folder same as the xml file

Gurneet gravatar image Gurneet  ( 2015-12-05 00:37:28 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 

Question Tools

1 follower

Stats

Asked: 2015-11-29 10:27:08 -0500

Seen: 133 times

Last updated: Nov 30 '15