Question-and-Answer Resource for the Building Energy Modeling Community
Get s tarted with the Help page
Ask Your Question
6

Proportional Outdoor Air Control with a Minimum Fraction Limit

asked 2015-10-28 23:41:53 -0500

updated 2017-05-17 12:31:37 -0500

I am trying to control a VAV air loop outdoor air flow rate to be proportional to the VAV air loop flow rate, however for the outdoor air flow rate, I want to add a minimum limit as a fraction of the design outdoor air flow rate.

See the following diagram, in which the red line shows the desired outdoor air flow as a function of the main air loop flow rate.

image description

To achieve the proportional control behavior, in the "Controller:OutdoorAir" object, I set the "Minimum Limit Type" to "ProportionalMinimum". However I am not sure how to impose the minimum outdoor air fraction limit (the horizontal line). I have tried to set the "Minimum Outdoor Air Schedule", "Minimum Fraction of Outdoor Air Schedule" and the "Maximum Fraction of Outdoor Air Schedule". But still was not able to achieve the desired minimum outdoor air limit. Want to check whether this is actually doable in EnergyPlus.

The IDF file I used is attached here: link text

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
8

answered 2015-10-29 01:44:47 -0500

updated 2015-10-29 11:56:17 -0500

You need to use EMS for the control.
Here is an example code for your case. Replace the "VAV_System_Default OA Controller" with the name of your "Controller:OutdoorAir". And change the xxx, yyy, zzz to your control parameter.

EnergyManagementSystem:Actuator,
VAV_System_Default_OA_Flow_Rate,    !- Name
VAV_System_Default OA Controller,    !- Actuated Component Unique Name
Outdoor Air Controller,    !- Actuated Component Type
Air Mass Flow Rate;        !- Actuated Component Control Type

EnergyManagementSystem:Program,
Set_VAV_System_Default_OA_Flow_Rate,    !- Name
IF totalAirFlow < xxx,    !-  xxx is your changing point of the total flow rate in kg/s
Set VAV_System_Default_OA_Flow_Rate = yyy,    !- yyy is your minimum OA flow rate in kg/s
ELSE,
Set VAV_System_Default_OA_Flow_Rate = totalAirFlow * zzz, !- zzz is your proportional ratio
ENDIF;                    !- End of code

EnergyManagementSystem:Sensor,
totalAirFlow,
VAV_System_Default OA Controller,
Air System Mixed Air Mass Flow Rate; 

EnergyManagementSystem:ProgramCallingManager,
Control_VAV_System_Default_OA_Flow_Rate,    !- Name
AfterPredictorAfterHVACManagers,    !- EnergyPlus Model Calling Point
Set_VAV_System_Default_OA_Flow_Rate;    !- Program Name 1
edit flag offensive delete link more

Comments

Yixing,

Thanks for sharing the EMS code. I copied the code and made minor modifications. The modified IDF is here . When I plot the result, I noticed that only 1 data point is below the specified minimum. Which should not be a big deal. But just curious what could have caused that outlier point?

TiejunWu gravatar image TiejunWu  ( 2015-10-29 15:31:24 -0500 )edit

@TiejunWu You can check the EMS document at page 28-30 for the calling points. Depend on your HVAC system, the value may be changed after the "AfterPredictorAfterHVACManagers" point.

Yixing Chen gravatar image Yixing Chen  ( 2015-10-30 16:15:40 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 

Question Tools

1 follower

Stats

Asked: 2015-10-28 23:41:53 -0500

Seen: 325 times

Last updated: Oct 29 '15