Question-and-Answer Resource for the Building Energy Modeling Community
Get s tarted with the Help page
Ask Your Question
3

Import IFC file to OpenStudio

asked 2015-10-02 10:15:50 -0500

Aida gravatar image

updated 2015-11-09 13:23:57 -0500

I tried to import IFC file to OpenStudio. First time I got a message for BIM server setting. I found out, how can I address this message.

But now when I click the File/import/ IFC, nothing shows up. Any message from BIMserver setting, even on my mac system. Where is the problem. how can I solve it?

Thank you

edit retag flag offensive close merge delete

Comments

What version of OpenStudio are you using, 1.9.0?

David Goldwasser gravatar image David Goldwasser  ( 2015-10-02 11:02:32 -0500 )edit

I tried on both 1.8.0 and 1.9.0.

Aida gravatar image Aida  ( 2015-10-02 11:20:40 -0500 )edit

Hi, this is Chong from the developer team of this function. This is a problem caused by version 1.8.0 and I can help you to resolve it. What is the operating system are you using?

Chong gravatar image Chong  ( 2015-10-02 11:31:14 -0500 )edit

Hi I really appreciate Chong. The operating system is Windows 7 64 bits/ Intel R core i7

Aida gravatar image Aida  ( 2015-10-02 15:15:42 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
4

answered 2015-10-02 16:36:35 -0500

Chong gravatar image

updated 2015-10-02 16:58:55 -0500

The problem is that: the program stored BIMserver settings in the computer, usually registry, and read it automatically next time. In version 1.8.0, this bug will appear if you click OK at the settings prompt without any inputs. Next time the program runs, it will read the empty settings in so that the settings prompt will not pop out (We try to reuse the settings so that you don't need to enter BIMserver credentials every time). Version 1.9.0 fixed this issue and will not write the empty settings. But if the empty settings is already there(created by v 1.8), then the settings prompt will still not pop up.

Solution: go to your registry in run->regedit.exe In HKEY_CURRENT_USER -> Software -> OpenStudio -> BIMserverConnection, delete all four attributes(addr, port, psw, usrname) by simply selecting all four name, right click, Delete. Now if you retry the application, it should work.

Note that the Import from IFC function needs to pair with BIMserver to be able to function normally (You don't need to learn how to use BIMserver, you just need it running properly in the background with a OSMSerializer plugin that we developed.). Please follow this tutorial to download and setup BIMserver: http://nrel.github.io/OpenStudio-user...

In Mac, there isn't a registry, but you can find the setting under your home directory: In Finder, Go->Home -> Library (if you can't see this folder, right click anywhere in your home folder->show view options, check "show Library Folder") -> Preferences, delete the com.openstudio.BIMserverConnection.plist file. Then restart the computer, this problem should be solved.

Please let me know if it solves your problem.

edit flag offensive delete link more

Comments

Thank you very much I could solve the problem. However, I try to import the IFC file from Import project, I have done the steps as the tutorial. When I push download OSM file. this message appear: No SerializerPluginConfiguration found where name = Osm. What should I do now?C:\fakepath\Sans titre.png

Aida gravatar image Aida  ( 2015-10-09 10:51:30 -0500 )edit

Hi Aida, It seems that you haven't added our BIMserver Plugin(OSMSerializer) into BIMserver. Please download the latest OSMSerializer from here https://github.com/BIMDataHub/OsmSeri... and put it under the BIMserver/plugin folder. Then restart BIMserver, and retry the download.

Chong gravatar image Chong  ( 2015-10-09 12:57:29 -0500 )edit

Hi there, Im running into a problem whilst putting the plugin in the folder. For some reason the program doesnt seem to recoginze the folder or the contents of the folder. How should i extract the folder with the newest OSMSerializer? Just place the folder there? Or extract it in some way?

AdriaanW gravatar image AdriaanW  ( 2016-05-02 09:38:11 -0500 )edit

When the BIMserver popup opens on Open studio, I enter the BIMserves information as required. But I never connect to the BIM server. I have entered many times and checked repeatedly my infos. They are certainly correct. What should I do to get over this step. The message after entering the info is: "BIMserver disconnected. BIMserver is not connected correctly. Please check if BIMserver is running and make sure your user name and password are valid.

yavi gravatar image yavi  ( 2017-04-12 05:10:44 -0500 )edit

hi yavi , i am exactly having the same problem. Have you been able to connect and how?

Rajan gravatar image Rajan  ( 2017-06-01 18:13:00 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 

Question Tools

1 follower

Stats

Asked: 2015-10-02 10:13:51 -0500

Seen: 1,003 times

Last updated: Oct 02 '15