Question-and-Answer Resource for the Building Energy Modeling Community
Get started with the Help page
Ask Your Question

Trouble using Space Infiltration Effective Leakage Area in Openstudio

asked 2015-09-23 16:43:42 -0500

Jerry K's avatar


I am finding that I am not able to define infiltration by Effective Leakage Area in Openstudio. When I attempt to do so, I receive in error regarding my zone infiltration object reading: Field [Zone Name] is required but was left blank.

I believe the error might be telling me to define the Effective Leakage Area to a thermal zone? I do not see an option or way to do so.

I am adding my effective leakage area using the inspector within the Sketchup interface, assigning a space where requested, and filling in the rest of the fields.


edit retag flag offensive close merge delete


Is the space that you assigned the infiltration object to, assigned to a thermal zone?

David Goldwasser's avatar David Goldwasser  ( 2015-09-23 19:56:42 -0500 )edit

Yes, the space is part of a thermal zone.

Also, I have no trouble creating an infiltration object using design flow rates.

Jerry K's avatar Jerry K  ( 2015-09-23 22:52:35 -0500 )edit

Is it possible you have an extra unused space infiltration effective leakage area object? The only way I was able to get the error you see is by not associating it with a space or space type.

I do see a different error if you use the default stack and wind coefficients that come with a new object made with the inspector, this issue doesn't exist if you use the Library in the OS app to add a new object.

   ** Severe  ** IP: IDF line~326 Invalid Number in Numeric Field#3 (Wind Coefficient), value=-1.#QNAN, in ZONEINFILTRATION:EFFECTIVELEAKAGEAREA=SPACE INFILTRATION EFFECTIVE LEAKAGE AREA 1
David Goldwasser's avatar David Goldwasser  ( 2015-09-24 13:25:32 -0500 )edit

No, just one effective leakage area object.

My library doesn't come with a default leakage object, so I haven't added one by that method.

Thanks for looking into this, David. I'll keep trying to figure out what's going wrong.

Jerry K's avatar Jerry K  ( 2015-09-24 14:30:01 -0500 )edit

1.9.0 due out soon will have this in "My Library" You will be able to drag it in to the space types tab or the new spaces tab.

David Goldwasser's avatar David Goldwasser  ( 2015-09-24 15:06:12 -0500 )edit

1 Answer

Sort by » oldest newest most voted

answered 2015-09-24 18:36:54 -0500

Jerry K's avatar

Ok, I got my model to run now with an infiltration leakage area. I assigned my effective leakage object to specific spaces (not space types) using the facility tab (not the space types tab as I have been previously assigning my design flow rate infiltrations.)

edit flag offensive delete link more


It should work on SpaceType as well, but we can try to figure out why it wasn't working for you if it happens again.

David Goldwasser's avatar David Goldwasser  ( 2015-09-25 12:02:19 -0500 )edit

Also, am I correct that the stack coefficient should be in (L/s)^2/(m^4·K) as opposed to (L/s)^2/(cm^4·K) as is found in the ASHRAE tables? When I use the coefficient converted to meters to the fourth power, my air changes per hour seem to make sense.

The object within Openstudio doesn't specify what units to use for the coefficients, so I'm a bit unsure what is to be inserted.

Jerry K's avatar Jerry K  ( 2015-09-25 15:46:53 -0500 )edit

refer to the EnergyPlus documentation for that object. It doesn't appear we do any unit conversion on it in OpenStudio.

David Goldwasser's avatar David Goldwasser  ( 2015-09-25 16:41:51 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2015-09-23 16:43:42 -0500

Seen: 520 times

Last updated: Sep 24 '15