Question-and-Answer Resource for the Building Energy Modeling Community
Get s tarted with the Help page
Ask Your Question
2

Why are the calculated volumes of my zones so large?

asked 2015-08-25 17:23:23 -0500

updated 2015-08-26 05:14:07 -0500

I'm finding a strange mismatch between zone area and zone volume in some models I'm building. In the affected models this is having the knock-on effect that a huge amount of heating energy is used, since the infiltration rate is specified as air changes per hour. The tables below show the issue I'm seeing. The first shows the very large volume but with the expected ([edit] or at least reasonable looking) floor and wall areas.

image description

The second shows a more normal volume (for a bigger building) and again expected/reasonable wall and floor areas. This second model was been produced using the same Python script, but with different footprint as input.

image description

An example IDF with the problem is here in case that helps.

The strange thing is that of approximately 45 buildings, roughly half show this problem while the other half appear normal. What could be causing this effect?

edit retag flag offensive close merge delete

Comments

1

Have you tried opening the file in the OpenStudio SketchUp plug-in (new one or legacy version) and seeing if anything jumps out at you?

macumber gravatar image macumber  ( 2015-08-25 17:49:11 -0500 )edit

Good idea, I'll give it a try

Jamie Bull gravatar image Jamie Bull  ( 2015-08-25 17:51:01 -0500 )edit

Hmm, yes definitely something wrong with my geometry. It won't import at all and gives message about subdividing surfaces. Warning: A surface was subdivided because of connected geometry.Added new surface Surface 1You should check your geometry carefully for mistakes.

Jamie Bull gravatar image Jamie Bull  ( 2015-08-25 18:07:58 -0500 )edit

Actually it did import, just a long way from the origin. Definitely a mistake in my geometry!

Jamie Bull gravatar image Jamie Bull  ( 2015-08-25 18:13:05 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
8

answered 2015-08-25 19:25:25 -0500

updated 2015-08-25 19:27:15 -0500

Although not an EnergyPlus error, here's the process I went through to track down and fix the problem using Eppy and OpenStudio/Sketchup.

1.Try and open the IDF in OpenStudio SketchUp plugin, thanks to @macumber's comment, and find it looked like this:

image description

2.Realise that points are not being drawn in the right sequence.

3.Run some tests using Eppy to create minimal zone models in the form of 3-, 4- and 5-sided zones, opening each in OpenStudio to see the result. You can make an empty IDF really quickly as shown here and then run geometry and zone generation code.

4.Find the first error is on the 5-sided zone which led to the error. I was using % 4 rather than % len(footprint) when creating floors and ceilings/roofs, based on some reused code for rectangular buildings.

5.Fix the bug and then... image description

Happy ending, time for bed!

Still no idea why EnergyPlus read that mess of a model as having a huge volume, but not others generated with the same buggy code. If anyone has any thoughts I'd love to know.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 

Question Tools

1 follower

Stats

Asked: 2015-08-25 17:23:23 -0500

Seen: 470 times

Last updated: Aug 26 '15